通达信公式指标源码:九转趋势主图

时间:2019-09-01 18:29 文章来源:无道配资 点击次数::

原文标题:通达信公式指标源码:九转趋势主图


通达信公式指标源码:九转趋势主图 Z1:=STRCAT(HYBLOCK,' '); Z2:=STRCAT(Z1,DYBLOCK); Z3:=STRCAT(Z2,' '); DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORRED; ZK1:(XMA(XMA(H,25),25)-XMA(XMA(L,25),25

通达信公式指标源码:九转趋势主图

复星医药600196股票最新价格

Z1:=STRCAT(HYBLOCK,' ');

Z2:=STRCAT(Z1,DYBLOCK);

Z3:=STRCAT(Z2,' ');

DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORRED;

ZK1:(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),DOTLINE,COLORBLUE;

ZD1:XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,LINETHICK3,COLORRED;

ZD2:EMA(ZD1,25),LINETHICK3,COLORGREEN;

DRAWBAND(ZD1,RGB(55,0,0),ZD2,RGB(0,91,0));

DRAWKLINE(H,O,L,C);

STICKLINE(ZD1>LOW AND ZD1<HIGH,ZD1,MIN(MIN(OPEN,CLOSE),ZD1),2,0),COLORYELLOW;

STICKLINE(ZD1>MIN(C,O) AND ZD1<MAX(C,O),ZD1,MIN(OPEN,CLOSE),2,0),COLORYELLOW;

STICKLINE(ZD1>HIGH,OPEN,CLOSE,2,0),COLORYELLOW;

STICKLINE(ZD1>HIGH,HIGH,LOW,0,0),COLORYELLOW;

VAR23:=100*XMA(XMA((C-REF(C,1)),6),6)/XMA(XMA(ABS((C-REF(C,1))),6),6);

回调买:=LLV(VAR23,2)=LLV(VAR23,7) AND COUNT(VAR23<0,2) AND CROSS(VAR23,MA(VAR23,2));

XG:=ZD1>HIGH AND 回调买 AND L<=ZD1;

DRAWTEXT(XG,L,'▲买入'),COLORRED;

JJ:=(HIGH+LOW+CLOSE)/3;

QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);

QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));

QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));

QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));

QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));

DDX:=((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,10000,10000),COLOR00AAAA,LINETHICK;

V2:=SMA(IF(C>=REF(C,1),DDX,-DDX/100),2,1);

V5:=SMA(V2*120/FROMOPEN*5,2,1);

V10:=SMA(V5,5,1);

V20:=SMA(V10,5,1);

DY:=CURRBARSCOUNT=1 AND C<REF(C,1);

DY2:=REF(V2,1)-DY;

XG2:=C>O AND DY2<0.02 AND MA(C,5)>MA(C,60) AND C/REF(C,1)>=1.02 AND H<ZK1;

{DRAWTEXT(XG2,L,'▲抓牛'),COLORYELLOW;}

DRAWTEXT(XG2 AND L<ZD1,L,'↖黑马暴涨'),COLORRED;

高1:=REF(HHV(3,80),3);

低1:=REF(LLV(L,3),3);

H1:=高1-(高1-低1)*0.191;

H2:=高1-(高1-低1)*0.382;

H3:=高1-(高1-低1)*0.5;

H4:=高1-(高1-低1)*0.618;

H5:=高1-(高1-低1)*0.809;

高:REFDATE(高1,DATE);

低:REFDATE(低1,DATE);

一:REFDATE(H1,DATE);

二:REFDATE(H2,DATE);

三:REFDATE(H3,DATE);

四:REFDATE(H4,DATE),COLORRED;

五:REFDATE(H5,DATE);

{DRAWTEXT(CURRBARSCOUNT=1.00,一,'一(0.191)'),COLORYELLOW;

DRAWTEXT(CURRBARSCOUNT=1.00,二,'二(0.382)'),COLORYELLOW;

DRAWTEXT(CURRBARSCOUNT=1.00,三,'三(0.50)'),COLORYELLOW;

DRAWTEXT(CURRBARSCOUNT=1.00,四,'四(0.618'),COLORYELLOW;


本文由无道配资整理编辑发布,地址:http://wudaoseo.com/1059.html,转载请注明出处!

相关内容