通达信公式指标源码:MACD神物

时间:2019-09-05 21:28 文章来源:无道配资 点击次数::

原文标题:通达信公式指标源码:MACD神物


通达信公式指标源码:MACD神物 {①顶背离,底背离提示(形成会有文字提醒,钝化不代表一定会形成) ②高九,低九(遇9就转,有朋友说有未来也是在这里,出7或8有的情况下不一定会出9,创新低或创新高7或8会消失,但9只要出现就不会更改,也

通达信公式指标源码:MACD神物

复星医药600196股票最新价格

{①顶背离,底背离提示(形成会有文字提醒,钝化不代表一定会形成)

②高九,低九(遇9就转,有朋友说有未来也是在这里,出7或8有的情况下不一定会出9,创新低或创新高7或8会消失,但9只要出现就不会更改,也不会漂移,只看9操作就可以)

③MACD买点(红色三角形)

④MACD低买(轴下金叉)

⑤MACD加油(轴上金叉)

⑥MACD翻红(二次买点)}

DRAWGBK(O>C,RGB(40,40,40),RGB(0,0,40),0,'01',0); {背景不要可删除}

DIF:100*(EMA(CLOSE,12)-EMA(CLOSE,26)),COLORWHITE,LINETHICK1;

DEA:EMA(DIF,9),COLORYELLOW,LINETHICK1;

MACD:(DIF-DEA)*2,COLORSTICK;

{

STICKLINE((MACD>=0),0,MACD,2,-1),COLOR0000FF;

STICKLINE(((MACD>=0) AND (MACD < REF(MACD,1))),0,MACD,2,0),COLOR0090FF;

STICKLINE((MACD<0),0,MACD,2,0),COLORGREEN;

STICKLINE(((MACD<0) AND (MACD > REF(MACD,1))),0,MACD,2,-1),COLORCYAN;

STICKLINE(CROSS(DIF,0),0,MACD,2,0)COLORMAGENTA;

STICKLINE(CROSS(0,DIF),0,MACD,2,0)COLORWHITE;

}

STICKLINE((MACD>=0),0,MACD,1,0),COLOR0000FF;

STICKLINE(((MACD>=0) AND (MACD < REF(MACD,1))),0,MACD,1,-1),COLOR0090FF;

STICKLINE((MACD<0),0,MACD,1,1),COLORGREEN;

STICKLINE(((MACD<0) AND (MACD > REF(MACD,1))),0,MACD,1,0),COLORCYAN;

STICKLINE(CROSS(DIF,0),0,MACD,1,0),COLORMAGENTA;

STICKLINE(CROSS(0,DIF),0,MACD,1,0),COLORWHITE;

FH1:=REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3)<REF(MACD,4);

FH2:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1;

FH3:=FH1 AND FH2 AND EMA(C,13)>REF(EMA(C,13),1);

FH4:=FH1 AND FH2 AND ABS((DIF-DEA)/C)<0.018;

FH5:=FH1 AND FH2 AND MACD<0.10;

二次翻红:(FH3 OR FH4 OR FH5),COLORRED,NODRAW;

低买:CROSS(DIF,DEA) AND DIF<0,COLORFF00FF,NODRAW;

加油:CROSS(DIF,DEA) AND DIF>0,COLORYELLOW,NODRAW;

DRAWICON(二次翻红,-0.05,1);

DRAWTEXT(二次翻红,-0.15,'↖翻红'),COLORRED;

DRAWTEXT(CROSS(DIF,DEA) AND DIF<0,DEA-0.02,'↖低买'),COLORFF00FF;

DRAWTEXT(CROSS(DIF,DEA) AND DIF>0,DEA-0.05,'↖加油'),COLORYELLOW;

XG:二次翻红 OR 低买 OR 加油,NODRAW;

YLZC:=IF(CLOSE=INDEXC,(INDEXC+INDEXH+INDEXL+INDEXO)/4,AMOUNT/(VOL+0.01)/100);

A1:=C>REF(C,4);

NT:=BARSLASTCOUNT(A1);

TJ11:=NT=9;

TJ13:=ISLASTBAR AND BETWEEN(NT,5,8);

AY:=(BACKSET(TJ11>0,9) OR BACKSET(TJ13>0,NT))*NT;

DRAWTEXT(AY>0,MACD*1.02,VAR2STR(AY,0)),COLORLIRED;

DRAWTEXT(NT=9,MACD*1.02,'9'),COLORGREEN;

B1:=C<REF(C,4);

NT0:=BARSLASTCOUNT(B1);

TJ21:=NT0=9 ;

TJ23:=ISLASTBAR AND BETWEEN(NT0,5,8);


本文由无道配资整理编辑发布,地址:http://wudaoseo.com/1343.html,转载请注明出处!

相关内容