通达信公式指标源码:抓牛法宝主图

时间:2019-09-05 21:28 文章来源:无道配资 点击次数::

原文标题:通达信公式指标源码:抓牛法宝主图


通达信公式指标源码:抓牛法宝主图 {筹码带} N:=10; TA:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW)); ATR:=EMA(TA,21); VAR81:=REF(CLOSE,N)-REF(ATR,1); 筹码线:=HHV(VAR81,21),COLORYELL

通达信公式指标源码:抓牛法宝主图

复星医药600196股票最新价格

{筹码带}

N:=10;

TA:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));

ATR:=EMA(TA,21);

VAR81:=REF(CLOSE,N)-REF(ATR,1);

筹码线:=HHV(VAR81,21),COLORYELLOW;

上:=(1+7/100)*筹码线;

下:=(1-7/100)*筹码线;

中:=(上+下)/2;

XGD:DRAWBAND(上,RGB(258,88,1),下,RGB(258,88,1));

{XGD:DRAWBAND(上,RGB(136,30,0),下,RGB(0,0,0));}

UPPER: MA(CLOSE,60)+ 2*STD(CLOSE,60),LINETHICK2,COLORFFFF00;

LOWER: MA(CLOSE,60)- 2*STD(CLOSE,60),LINETHICK2,COLORFFFF00;

{UPPER90: MA(CLOSE,90)+ 2*STD(CLOSE,90),LINETHICK2,COLORC080FF;

LOWER90: MA(CLOSE,90)- 2*STD(CLOSE,90),LINETHICK2,COLORC080FF;}

{盖住双横杠}

F:=C/O;

STICKLINE(F>=1,C,O,2.8,1),COLORRED;

STICKLINE(F>=1,C,H,0.00001,0),COLORRED;

STICKLINE(F>=1,L,O,0.00001,0),COLORRED;

STICKLINE(F<1,C,O,2.8,0),COLORCYAN;

STICKLINE(F<1,O,H,0.00001,0),COLORCYAN;

STICKLINE(F<1,L,C,0.00001,0),COLORCYAN;

{牛熊线}

短期线:EMA(CLOSE,7),COLORWHITE,LINETHICK1;

中期线:EMA(CLOSE,25),COLORFF00FF,LINETHICK1;

长期线MACP:EMA(中期线,55),COLORYELLOW,LINETHICK2;

牛熊分水岭905:EMA(CLOSE,905),COLORRED,LINETHICK3;

大牛控盘线:MA(CLOSE,1650),COLORGREEN,LINETHICK3;

X_3:=MAX(DYNAINFO(3),DYNAINFO(5));

X_4:=MIN(DYNAINFO(3),DYNAINFO(6));

银河线:=(X_3-X_4);

DRAWICON(CROSS(中期线,长期线MACP),长期线MACP,23);

VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);

VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);

VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);

VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);

本文由无道配资整理编辑发布,地址:http://wudaoseo.com/1353.html,转载请注明出处!

相关内容